En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 

GuppY, le CMS de référence sans base de données

 

telecharger01.png

 
 
Vous êtes ici :   Accueil » Forum » Guppy 5 » Restriction accés groupe privé ne fonctionne plus
 
    Imprimer la page...
    Imprimer la section...
 

Attention : GuppY 5.03.00

Sortie de GuppY 5.03.00 :
 

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont en téléchargement.


Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (24.09.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5

Forum - Guppy 5 - Restriction accés groupe privé ne fonctionne plus



le 11/01/2019 @ 22:05
par Franck2A

Franck2A

37 messages

Bonsoir,

J'ai des articles qui sont normalement réservés à un groupe privé.

Cette restriction fonctionnait parfaitement, mais je viens de m'apercevoir que ce n'est plus le cas.

Ces articles sont maintenant publics alors que le champ "Accès réservé au groupe privé" est bien positionné dans l'admin.

J'ai nettoyé le cache des navigateurs pour ôter ce doute, mais cela ne change rien.

Je ne peux pas l'affirmer, mais j'ai fait la mise à jour 5.02.08 récemment et je suspecte que cela soit lié.

Lien vers un article normalement restreint ICI.

Guppy 5.02.08

Je vous remercie pour votre aide

Poster une réponse Haut  
Réponse n° 1
--------
le 12/01/2019 @ 10:26
par Saxbar

Saxbar

Développeur
90 messages

Bonjour,

Effectivement çà fonctionne pour Tous les membres, pas pour d'autres groupes d'utilisateurs.

Nous y regardons.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 2
--------
le 13/01/2019 @ 15:35
par Saxbar

Saxbar

Développeur
94 messages

Bonjour,

Après vérifications, l'accès réservé à un article à un groupe de membres fonctionne parfaitement.

Tu peux essayer de refaire une mise à jour avec le patch cumulatif 5.02.08 cette fois, pour éliminer un éventuel fichier corrompu, les données ne risquent rien.

Si le problème persiste il faudra envisager une recherche par FTP.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 3
--------
le 13/01/2019 @ 19:05
par Franck2A

Franck2A

38 messages

Bonsoir Saxbar,

Je viens de refaire la mise à jour avec le patch cumulatif 5.02.08, le comportement non souhaité persiste.

Merci pour ton aide.

Poster une réponse Haut  
Réponse n° 4
--------
le 25/01/2019 @ 21:04
par Franck2A

Franck2A

39 messages

Bonsoir,

Je me permets de remonter ce sujet, car j'attendais un retour mais je n'ai peut-être pas bien interprété la dernière réponse.

Serait-il possible d'avoir une piste sur les éléments anormaux à détecter.

J'ai vérifié les droits sur le fichiers et dossier et cela semble conforme.

Je vous remercie pour votre aide.

Poster une réponse Haut  
Réponse n° 5
--------
le 26/01/2019 @ 19:57
par Saxbar

Saxbar

Développeur
104 messages

Bonsoir Frank,

Nous avons fait des essais en ligne avec Papinou sur des sites de tests différents, les articles sont bien visibles des membres connectés des groupes concernés.

Peux-tu nous confirmer que tu as bien affecter le ou les groupes d'utilisateurs à l'item Accès réservé au groupe privé dans les articles et les options de menu concernés ?

Si c'est bien le cas, tu peux nous envoyer les identifiants suivants pour l'un des sites sur lequel tu as le problème :

  • pseudo et mot de passe de l'admin principal
  • identifiants FTP (hôte, utilisateur, mot de passe)

Nous y regarderons le plus rapidement possible.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 6
--------
le 28/01/2019 @ 09:39
par Franck2A

Franck2A

40 messages

Bonjour Saxbar,

Les articles sont bien en "Accès réservé au groupe privé".

J'ai peut-être loupé quelque chose, mais cette conf a fonctionné et je ne m'explique pas ce que j'ai pu faire qui aurait cassé quelque chose.

Je viens de vous envoyer les informations demandées via le formulaire de contact.

Je te remercie pour ton aide.

Poster une réponse Haut  
Réponse n° 7
--------
le 28/01/2019 @ 10:46
par Saxbar

Saxbar

Développeur
107 messages

Bonjour,

Bien reçu tes identifiants, je vois çà le plus rapidement possible.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 8
--------
le 28/01/2019 @ 19:56
par Saxbar

Saxbar

Développeur
108 messages

Bonsoir Frank,

Je viens de t'envoyer un email pour les détails de l'intervention.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 9
--------
le 28/01/2019 @ 22:01
par anne_b64

anne_b64

715 messages

Bonsoir

J'ai le même problème sur 2 sites où j'avais mis en place des accès privés, tout est maintenant en en accès libre.

Site 1

GuppY 5.02.08 Système d'exploitation du serveur : Linux 4.14.66-ovh-vps-grsec-zfs-classid PHP : 7.2.14 / MET=300 - ML=512M - UMF=128M - PMS=130M - MFU=20 URL du site : https://www.adour-bridge.com/ Plugins : ArchNwsl[1.2], Horloge, Devinette, Vitesse de Connexion UA: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0 Device: computer Résolution écran : 1920x1080  

Site 2

GuppY 5.02.08 Système d'exploitation du serveur : Linux 4.14.66-ovh-vps-grsec-zfs-classid PHP : 7.0.33 / MET=300 - ML=512M - UMF=128M - PMS=130M - MFU=20 URL du site : https://www.bridge-oloron.fr/ UA: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0 Device: computer Résolution écran : 1366x768  

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
Réponse n° 10
--------
le 29/01/2019 @ 09:30
par Franck2A

Franck2A

41 messages

Bonjour Saxbar,

Je te remercie pour l'intervention.

J'ai répondu à ton mail pour t'expliquer les nouvelles constations suite à cette intervention.

Cordialement

Poster une réponse Haut  
Réponse n° 11
--------
le 29/01/2019 @ 09:39
par Saxbar

Saxbar

Développeur
109 messages

Bonjour Frank,

Comme je te l'expliquais dans le compte-rendu, dans tes menus déroulants les adresses vers articles ne doivent pas comporter de référence à un menu classique.

En fonction de la liste d'articles que tu m'a donnée je vais les corriger, mais je t'invite ensuite à faire le ménage dans tes liens des menus déroulants, en supprimant les &mnuid=NNN, NNN étant un numéro de menu classique.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 12
--------
le 29/01/2019 @ 09:45
par Saxbar

Saxbar

Développeur
110 messages

Bonjour Anne,

Ton problème est différent de celui de Frank2A puisque tu n'a pas de menu déroulant pour tes articles.

Donc le problème vient d'ailleurs. Vérifie que les groupes affectés aux articles soient également affectés aux options de menus classiques.

Tu peux nous envoyer pour tes deux sites les identifiants habituels :

- pseudo et mot de passe de l'admin principal

- identifiants FTP (hôte, utilisateur, mot de passe)

Nous y regarderons dès que possible.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 13
--------
le 29/01/2019 @ 10:34
par anne_b64

anne_b64

716 messages

Bonjour

Merci Saxbar, j'ai envoyé les données demandées.

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
Réponse n° 14
--------
le 29/01/2019 @ 17:50
par anne_b64

anne_b64

717 messages

Bonjour

Je viens de tester sur l'ensemble de mes sites, en y créant des accès restreints, le problème se reproduit partout.

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
Réponse n° 15
--------
le 29/01/2019 @ 18:12
par Saxbar

Saxbar

Développeur
111 messages

Bonjour Anne,

Je viens de terminer les deux sites, c'est bien ce que je supposais, si un article et une option de menu sont liés, il doivent avoir la même restriction.

J'en ai fait plusieurs sur chaque site et çà fonctionne.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 16
--------
le 29/01/2019 @ 18:42
par anne_b64

anne_b64

718 messages

Bonsoir

Merci pour cette intervention Saxbar. Ce qui me pose problème, c'est que j'aimais bien l'idée d'avoir l'option de menu visible, ainsi, le membre qui ne faisait pas l'effort de se connecter était invité à le faire s'il cliquait sut l'option de menu dirigeant vers l'article protégé. Et en plus, ça invitait d'autres visiteurs à s'enregistrer comme membres.

Je ne sais pas si je me fais bien comprendre.

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
Réponse n° 17
--------
le 29/01/2019 @ 18:46
par Saxbar

Saxbar

Développeur
112 messages

Re,

C'est un point de vue qui se défend. Nous allons y réfléchir.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 18
--------
le 01/03/2019 @ 11:03
par anne_b64

anne_b64

719 messages

Bonjour

Je reviens sur ce fil, pour vous faire part d'une constatation. Je n'ai rien changé concernant les accès restreints sur mes sites. A savoir que j'ai conservé certains articles en accès restreint mais les options de menus associées non, afin qu'elles soient visibles de tous. Le clic sur ces options de menus offrait alors la lecture des articles à tous les visiteurs malgré la restriction mise sur l'article.

Il s'avère que maintenant, le clic sur ces options de menus affiche une page d'interdiction au membre ne faisant pas partie du groupe restreint. Donc, il me semble que cela fonctionne comme avant le signalement de ce dysfonctionnement.

Bonne journée.

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
Réponse n° 19
--------
le 01/03/2019 @ 11:25
par Saxbar

Saxbar

Développeur
135 messages

Bonjour Anne,

Tu retrouveras ce mode fonctionnement dans la prochaine version.

Cordialement, Saxbar.

Site web Saxbar
Poster une réponse Haut  
Réponse n° 20
--------
le 01/03/2019 @ 11:59
par anne_b64

anne_b64

720 messages

Mais tout me plaît déjà, puisque je peux protéger un article tout en laissant visible l'option de menu. Sur mes sites de production, tout est redevenu comme cela. Ou alors ils ont été patchés avec la version suivante non existante encore, à l'insu de mon plein gré? eekwink

Cordialement, Anne
Membre de l'asso

Poster une réponse Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter