En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 

GuppY, le CMS de référence sans base de données

 

telecharger01.png

 
 
Vous êtes ici :   Accueil » Forum » Guppy 5 » Fatal error: ... blog.php on line 152
 
    Imprimer la page...
    Imprimer la section...
 

Attention : GuppY 5.03.00

Sortie de GuppY 5.03.00 :
 

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont en téléchargement.


Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (24.09.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5

Forum - Guppy 5 - Fatal error: ... blog.php on line 152


Connectés :
 

clos par Papinou le 28/03/2019 @ 09:05  Sujet n° 130423

le 23/03/2019 @ 10:58
par jblagrange

jblagrange

4 messages

Bonjour,

lorsqu'on clique sur un lien dans la partie blog de la boîte nouveauté, on obtient une invitation à se connecter puis

Fatal error: Using $this when not in object context in /home/avironhefz/www/blog.php on line 152

l'URL du lien est du type

http://avironhennebontais.bzh/blog.php?lng=fr&sel=pg&tconfig=0&pg=436

Note 1: j'ai l'erreur dans Chrome (Version 73.0.3683.86 (Build officiel) (64 bits)) et sur un smartphone,et dans IE 11

Note 2: quand on est connecté comme utilisateur, on obtient des infos sur la connexion (mon courrier, etc.) puis la page demandée.

Note 3: il n'y a pas de restriction à l'accès aux billets de blog: sans connexion. On accède via la page d'accueil ou la section dédiée via une URL du typehttp://avironhennebontais.bzh/blogs.php?lng=fr&sel=none&pg=0&cat=0&datej=0&date=0&id=1

Note 4: l'erreur ne se produit pas sur le lien analogue pour les nouvelles ou les liens, à partir de la boîte nouveautéshttp://avironhennebontais.bzh/news.php?lng=fr&pg=435&tconfig=1

GuppY 5.02.08 Système d'exploitation du serveur : Linux 4.14.66-ovh-vps-grsec-zfs-classid PHP : 5.6.39 / MET=300 - ML=512M - UMF=128M - PMS=130M - MFU=20 URL du site : http://avironhennebontais.bzh/ Plugins : Horloge, Devinette, Vitesse de Connexion UA: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko Device: computer Résolution écran : 1518x853   Merci de votre aide jbl

sujet clos Haut  

Réponse n° 1
--------
le 23/03/2019 @ 11:50
par Saxbar

Saxbar

Développeur
157 messages

Bonjour,

Dans la version 5.02.08 les boîtes du blog sont devenues indépendantes, elles se configurent dans Config accueil. Vérifie donc si ces boîtes sont bien sélectionnées, soit dans la colonne droite soit la gauche.

Si elles sont déjà présentes tu peux télécharger le patch cumulatif et l'installer en admin.

Cordialement, Saxbar.

Site web Saxbar
clos par Papinou le 28/03/2019 @ 09:05 Haut  
Réponse n° 2
--------
le 23/03/2019 @ 12:13
par jblagrange

jblagrange

5 messages

Merci de votre réponse.

Néanmoins, il s'agit d'une config mobile où je ne mets que les nouveautés en page d'accueil, et je ne vois pas quoi mettre dans les colonnes.

Je pensais aussi que j'ai la dernière version 5.02.08, donc quel patch faut-il appliquer ?

Le pb est que le lien vers une entrée de blog depuis les nouveautés demande une connexion, ce qui ne devrait pas. C'est d'ailleurs le même lien et la même erreur dans les titres de blog de la page d'accueil de la config web.

clos par Papinou le 28/03/2019 @ 09:05 Haut  
Réponse n° 3
--------
le 23/03/2019 @ 14:01
par Papinou

Papinou

Administrateur
456 messages

Bonjour,

Si tu le souhaites, tu nous envoies par Nous contacter dans la boite Infos Site le pseudo de l'administrateur principal et son mot de passe.

Nous vérifierons la configuration dès que possible.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Papinou le 28/03/2019 @ 09:05 Haut  
Réponse n° 4
--------
le 23/03/2019 @ 16:05
par Papinou

Papinou

Administrateur
457 messages

Bonjour,

La correction est faite, à Config Accueil/Blog pour la partie Blog, il n'y avait pas de boites sélectionnées.  
Maintenant tout doit être affiché correctement.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Papinou le 28/03/2019 @ 09:05 Haut  
Réponse n° 5
--------
le 23/03/2019 @ 23:50
par jblagrange

jblagrange

6 messages

Problème résolu. Semble venir de l'inscription comme collaborateur de l'administrateur principal (webmaster).

Merci

clos par Papinou le 28/03/2019 @ 09:05 Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter  
Catégories de discussion  Forum