En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.
 
 
 

GuppY, le CMS de référence sans base de données

 

telecharger.png

 
Vous êtes ici :   Accueil » Forum » Guppy 5 » Problème avec l'envoi de mail
 
 
 
    Imprimer la page...
    Imprimer la section...

Attention : GuppY 5.03.00

Sortie de GuppY 5.03.00 :
 

Les zips du pack, du patch cumulatif et du patch non-cumulatif sont mis à jour et en téléchargement le 17.01.2020 à 18h00.


Le patch CKEditor v4121 pour GuppY 502xx (06.07.2019) est en téléchargement dans la rubrique Télécharger puis GuppY 5. Merci à Saxbar pour cette mise à jour.

Mise à jour des listes de blocage des spams (24.09.2019) pour Apache 2.3 et pour Apache 2.4 en téléchargement dans la rubrique Télécharger puis GuppY 5

Forum - Guppy 5 - Problème avec l'envoi de mail


clos par Magellan le 14/04/2019 @ 20:22  Sujet n° 130438

le 03/04/2019 @ 19:34
par Magellan

Magellan

25 messages

Hello... Depuis mon déménagement chez 1&1 IONOS, j'ai essayé tous les modes d'envoi mail et aucun ne marche : quelque soit l'adresse (gmail, outlook.com) avec ou sans authentification, rien ne se passe et avec phpMailer j'ai cette erreur :

Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /homepages/15/d772764709/htdocs/inc/mail/class/PHPMailerAutoload.php on line 45Warning: Use of undefined constant eMsgTxt - assumed 'eMsgTxt' (this will throw an Error in a future version of PHP) in /homepages/15/d772764709/htdocs/inc/mail/phpmailer.inc on line 26 Mailer Error: You must provide at least one recipient email address.Warning: Use of undefined constant eMsgTxt - assumed 'eMsgTxt' (this will throw an Error in a future version of PHP) in /homepages/15/d772764709/htdocs/inc/mail/phpmailer.inc on line 26 Mailer Error: You must provide at least one recipient email address.

Quelle-est la config à utiliser pour Gmail ou Outlook ?

Merci pour votre aide.

P.S : Je sais que o2switch a l'air d'être un super hébergeur mais quand j'ai découvert votre partenariat qu'après avoir déjà migré chez 1&1...

sujet clos Haut  
Réponse n° 1
--------
le 03/04/2019 @ 21:03
par Papinou

Papinou

Administrateur
470 messages

Bonjour,

Pour l'envoi de mails depuis un site, tu relis ce tutoriel toujours d'actualité.

Obligatoirement un mail du domaine et courriel PHP standard ou standard_2 pour espérer avoir un résultat.

Si l'authentification du mail n'est pas bonne, c'est du spam d'office d'où la necessité d'utiliser un mail du domaine.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 2
--------
le 03/04/2019 @ 21:54
par Magellan

Magellan

26 messages

OK, j'ai crée un mail du domaine : webmaster@f4bpp.com

Les paramètres STMP sont

smtp.ionos.fr avec port 465/SSL ou 785/TLS.

Rien ne fonctionne, aucun mail est expédié ni avec PHP Standard, ni avec PHP Standard2 avec les deux ports...

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 3
--------
le 04/04/2019 @ 13:43
par Papinou

Papinou

Administrateur
471 messages

Bonjour,

En admin/config générale à Infos sur le webmestre, tu mets le pseudo, ton adresse mail du domaine et tu coches Courriel PHP.

Ensuite en admin/config services à Supervision, tu sélectionnes courriel PHP standard et toutes les rubriques qui doivent envoyer un message.

A la dernière ligne "Liste des courriels recevant la supervision" tu peux ajouter une adresse gmail, ça fonctionne.

Après cette vérification, si ça ne fonctionne pas, tu nous envoies l'accès de l'admin principal et les identifiants FTP pour nous permettre de tout vérifier.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 4
--------
le 04/04/2019 @ 21:06
par Magellan

Magellan

27 messages

Bonsoir, j'ai mis 2 adresses mails dans la liste des courriels recevant la supervision et ça a marché. J'ai reçu les notifications d'inscription sur les deux. En revanche, je n'ai rien reçu dans les boites mails avec lesquelles je me suis inscrit pour tester.

Dans le mode d'inscription j'ai choisi "*Confirmation par webmestre". Est-ce que par hasard, dans cette configuration celui qui s'inscrit ne reçoit aucun message de confirmation ? Si c'est le cas, je vais chercher un trou de souris et m'y planquer pour quelques temps...

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 5
--------
le 05/04/2019 @ 11:23
par Magellan

Magellan

28 messages

Avant que je clôture le sujet, est-ce que quelqu'un peut me confirmer si c'est normal qu'en mode "Confirmation par le webmestre" la personne qui s'inscrit ne reçoit aucun mail de confirmation ? Merci.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 6
--------
le 05/04/2019 @ 12:00
par Papinou

Papinou

Administrateur
472 messages

Bonjour,

Non ce n'est pas normal, lorsque le webmestre confirme la validation du compte, un mail est envoyé au membre inscrit.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 7
--------
le 05/04/2019 @ 12:53
par Magellan

Magellan

29 messages

Mais tant que le webmestre n'a rien confirmé, celui qui s'inscrit ne reçoit donc aucune confirmation par mail lui indiquant que son inscription a bien été prise en compte et qu'elle est en cours de validation par le webmestre ?

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 8
--------
le 05/04/2019 @ 13:57
par Papinou

Papinou

Administrateur
474 messages

Bonjour,

Dès l'inscription d'un membre, un mail est envoyé pour Confirmation par mail et Confirmation par le webmestre.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 9
--------
le 05/04/2019 @ 16:11
par Magellan

Magellan

30 messages

Ok. Mais est ce que dans le cadre d'une inscription qui doit être validée par le webmestre, le membre reçoit aussi un mail ou pas ? Pour l'instant, j'ai opté pour une confirmation d'inscription par le webmestre. Si dans les règlges de supervision, je ne mets pas de mail dans la "liste des courriels recevant la supervision", je ne suis pas informé de l'inscription d'un membre. Mais dans tous les cas, lui non plus ne reçoit pas de mail car j'ai testé en m'inscrivant avec une de mes adresses mails et je ne reçois rien. Donc est-ce que c'est normal ou pas ? Je n'ai pas testé avec une inscription classique à validation par courriel.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 10
--------
le 05/04/2019 @ 17:08
par Papinou

Papinou

Administrateur
475 messages

Bonjour,

Je pensais avoir été clair !!!

OUI, le membre doit recevoir un mail que ce soit Validation par mail ou Confirmation webmestre.

Comme tu reçois sur les courriels en copie, il faudrait vérifier la configuration de ton mail.

Cordialement, Papinou Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 11
--------
le 06/04/2019 @ 14:53
par Magellan

Magellan

31 messages

Désolé mais si j'ai posé la question c'est que cela ne l'était pas pour moi... mais à ma décharge, j'ai été surmené dans mon travail ces derniers jours et j'ai vraiment accumulé beaucoup de fatigue.

J'ai vérifié tous les paramètres et il me semble que rien ne cloche dans ma config.

Dans INFOS SUR LE Webmestre, j'ai :

  • Nom du Webmestre : magellan
  • Courriel du Webmestre : webmaster@f4bpp.com
  • Courriel PHP coché.

Dans SUPERVISION j'ai :

  • serveur smtp : smtp.ionos.fr
  • Avec authentification coché
  • Préfixe de connexion : tls
  • Numéro du port smtp : 587
  • Adresse courriel utilisateur : webmaster@f4bpp.com
  • Et mes mots de passe renseignés en dessous.
  • Courriel ouverture et fermeture de compte coché
  • Liste des courriels recevant la supervision : webmaster@f4bpp.com

Quelle que soit l'adresse mail que j'utilise pour m'enregistrer (free, outlook, gmail) je ne reçois rien, il n'y a que webmaster@f4bpp.com qui reçoit la notification d'ouverture de compte mais si je ne mets rien dans la liste des courriels recevant la supervision, je ne reçois rien du tout.

Rectifié par Magellan le 06/04/2019 @ 14:54


Rectifié par Magellan le 06/04/2019 @ 14:56
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 12
--------
le 06/04/2019 @ 15:16
par Papinou

Papinou

Administrateur
478 messages

Bonjour,

A " Type de courriel PHP", tu as sélectionné quelle option ?

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 13
--------
le 06/04/2019 @ 18:18
par JeanDenis

JeanDenis

1353 messages

Bonjour,

Je me permets de poster ici,

En effet, il est peut-être possible que le souci soit ailleurs...

Je viens de refaire des tests (sur 2 sites hébergés différemment et avec des modes de gestion du courriel différents : php standard et phpmailer ) et voilà ce que j'obtiens :

J'ai paramétré le mode d'inscription en "confirmation par webmestre"

J'ai testé plusieurs fois une inscription et je reçois le courriel de supervision (de ce côté tout va bien... ( et il semble que pour Magellan, c'était le cas...)

Mais j'ai essayé deux réactions du "webmestre"

1) Après avoir reçu l'information, il se connecte et, via son logiciel de messagerie clique sur le lien Accepter l'inscription :  qu'il a reçu.

Dans ce cas, tout va bien : l'inscription est validée et le futur membre reçoit une information de validation.

2) Après avoir reçu l'information, il se connecte et dans l'admin : gestion des membres, il édite le compte du futur membre et le valide "à la main".

Dans ce cas, le compte est bien validé, mais le futur membre ne reçoit rien...

C'est ce que j'ai constaté en tout cas...

Salutations,

Jean-Denis


www.71site.fr

Site web JeanDenis
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 14
--------
le 06/04/2019 @ 18:34
par Magellan

Magellan

32 messages

J'ai tout essayé.... PHP normal, 2, 3 et 4. Je ne reçois rien sur les adresses mail que j'utilise pour tester l'inscription, ni free, ni gmail, ni outlook.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 15
--------
le 07/04/2019 @ 11:31
par Magellan

Magellan

33 messages

Bonjour,

Je viens de tester à nouveau l'inscription.

Après inscription, le message suivant s'affiche pour celui qui vient de s'inscrire :

Votre demande est prise en compte, veuillez attendre la confirmation du webmaster !!!

L'adresse mail qui est paramétrée dans la "Liste des courriels recevant la supervision" reçoit bien la notification d'une nouvelle inscription et propose un lien qui permet d'accepter cette inscription.

Comme indiqué dans la doc, il faut être connecté avec le compte administrateur pour que ça fonctionne. Et effectivement, si on n'est pas connecté, ça ne fonctionne pas et si on clique sur le lien "accepter l'inscription", une page du site est ouverte dans le navigateur avec ce message :

Votre demande est prise en compte, veuillez répondre à notre courriel !

Et bien entendu il n'y a pas de courriel. Mais ce message me semble pas approprié. Il aurait été préférable de le remplacer par :

Veuillez vous connecter pour que, votre requête soit prise en compte !

Le top serait que, puisque c'est l'administrateur qui reçoit ce lien, ce dernier n'ait pas besoin de se connecter pour valider l'inscription du compte.

Par contre, si avant de cliquer sur le lien l'administrateur se connecte comme le préconise la doc, alors oui, celui qui s'inscrit reçoit bien un mail de confirmation et c'est le seul qu'il reçoit.

Et pour finir, je voudrais signaler que le captcha texte2 est quelquefois mal aligné sur la page car le dernier caractère est parfois affiché une ligne en dessous au début de la phrase "recopier les 4 caractères du code" qui de coup n'est plus alignée correctement.

Alors, "à un moment donné" comme on dit chez moi à Marseille, je veux bien faire des erreurs mais on ne peut pas tout me mettre sur le dos biggrin et je pense qu'il y a quelques petits soucis à régler dans le CMS car, si c'étaient mes paramètres qui étaient cause, aucun mail n'aurait été envoyé à partir du site et ce n'est pas le cas.

Quoi qu'il en soit, j'espère que vous allez trouver une solution pour régler ces petits problèmes. Et pour une fois je suis d'accord avec le message qui s'affiche après avoir posté un message sur le forum... "Merci pour votre contribution". En espérant que ces quelques lignes vous aident à comprendre les petits soucis que je rencontre et qu'apparemment je ne suis pas le seul à constater.

Cordialement, avec tous mes remerciements, David.

Rectifié par Magellan le 07/04/2019 @ 11:34

Rectifié par Magellan le 07/04/2019 @ 11:36


Rectifié par Magellan le 07/04/2019 @ 15:39
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 16
--------
le 08/04/2019 @ 10:18
par Papinou

Papinou

Administrateur
479 messages

Bonjour,

Citation :

"je veux bien faire des erreurs mais on ne peut pas tout me mettre sur le dos "

Ce n'est pas la question mais il y a quand même quelques principes à respecter.

Pour administrer un site, il faut impérativement: - être membre du site et connecté comme membre - être administrateur principal ou administrateur secondaire du site pour pouvoir entrer en admin   (les collaborateurs admin avec les droits nécessaires peuvent administrer le site)

Après tests et vérifications sur notre site de tests, tous les envois de mails fonctionnent chez ton hébergeur.

"je voudrais signaler que le captcha texte2 est quelquefois mal aligné sur la page"

Je viens de faire le tour des pages du site, sur aucune page je n'ai vu les caractères du captcha mal alignés.

Désolé mais pour régler les problèmes, il faudrait les identifier clairement et ce n'est pas le cas.

Je me suis inscrit sur ton site hier, mais j'attends toujours la validation du compte.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???


Rectifié par Papinou le 08/04/2019 @ 10:23
Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 17
--------
le 08/04/2019 @ 11:56
par Magellan

Magellan

34 messages

Merci Papinou. Je n'ai pas eu le mail de notification ou alors quand j'ai supprimé les mails de notifications de tous mes essais, il y avait le tien dedans qui est passé à la trappe... désolé. Quant au fait que tu ne reçoives rien, c'est le but de ce fil de discussion. Je viens d'accepter ton inscription et est mis ton pseudo en administrateur secondaire. Tu as la main sur le site.

Et pour le captcha, j'ai fait une copie d'écran, j'ai donc la preuve de ce que je dis :

https://f4bpp.com/Captcha.png

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 18
--------
le 08/04/2019 @ 13:43
par Papinou

Papinou

Administrateur
480 messages

Bonjour,

Pour le captcha, je n'ai pas le même affichage sur cette page.

Pour l'administrateur secondaire, il ne suffit pas de mettre le pseudo, il doit être collaborateur et avoir les droits de collaborateur admin (voir ce tuto).

Ce n'est pas correct au niveau des droits, je n'ai pas accès à l'admin.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 19
--------
le 08/04/2019 @ 15:28
par Magellan

Magellan

35 messages

Pardon... voilà c'est fait ! Journées portes ouvertes ! smile Merci.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 20
--------
le 08/04/2019 @ 15:35
par Papinou

Papinou

Administrateur
482 messages

Bonjour,

Maintenant, c'est bon, je vais vérifier la configuration et tester les mails si besoin.

Tu ne modifies rien avant mon prochain message sur ce fil.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 21
--------
le 08/04/2019 @ 16:45
par Papinou

Papinou

Administrateur
483 messages

Bonjour,

Pour Contact, avec l'adresse mail du domaine, et courriel PHP standard, c'est fonctionnel.

Il faut aussi une adresse mail du domaine, pas une adresse free.

Pour les mails d'inscription avec Confirmation par le webmestre:

- pour la réception par l'administrateur, ça fonctionne

mais un clic sur le lien pour Autoriser l'inscription ne fonctionne pas, le compte reste à "Confirmation par le webmestre" et le membre ne reçoit pas de mail.

En admin, un clic sur l'icône ? à Etat puis Accepté et le mail avec le lien pour se connecter est envoyé au membre avec le lien pour Se connecter.

Pour aller plus loin, tu nous envoies si tu le souhaites les indentifiants FTP : Hôte, Identifiant et mot de passe par Nous contacter dans la boite Infos Site pour nous permettre de vérifier les fichiers.

Soit un fichier est corrompu, soit il a été modifié ou pas mis à jour.

J'ai créé un autre membre pour les tests, je le laisse pour le moment.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 22
--------
le 08/04/2019 @ 17:30
par Magellan

Magellan

36 messages

OK, paramètres FTP envoyés via "Nous concter" de la boîte Info Site.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 23
--------
le 08/04/2019 @ 18:37
par Papinou

Papinou

Administrateur
484 messages

Bonjour,

C'est réparé et je pense que tout fonctionne.

Je viens de t'envoyer le détail par mail.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 24
--------
le 08/04/2019 @ 19:50
par Magellan

Magellan

37 messages

Merci beaucoup. Il y a juste un point dans ton mail que je n'ai pas compris :

Citation : « Papinou »

J'ai renvoyé pas mal de fichiers et j'ai oublié tes images pour les drapeaux, tu devras les remettre.

Sinon tu me dis que tout fonctionne mais tu ne m'as pas dit si l'erreur venait de moi ou d'un fichier corrompu.

Quoi qu'il en soit je vais tester tout ça demain et te ferai un retour. je suis heureux que tout soit rentré dans l'ordre.

Merciiiii !

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 25
--------
le 10/04/2019 @ 22:28
par Magellan

Magellan

38 messages

Bonsoir,

Voici le résultat des tests : Quand un membre s'inscrit, il ne reçoit pas de courriel. En revanche, quand je valide son inscription, il reçoit bien un mail de confirmation toujours mais pas de mail pour lui dire que son inscription a bien été prise en compte. Avec le mode d'inscription "Validation par le webmestre" je présume que c'est normal.

Merci pour l'intervention sur mon site pour recaler les choses. Cependant, depuis j'ai deux articles avec une Iframe que ne s'affichent plus :

https://f4bpp.com/articles.php?lng=fr&pg=177&tconfig=0

https://f4bpp.com/articles.php?lng=fr&pg=165&tconfig=0

https://f4bpp.com/articles.php?lng=fr&pg=175&tconfig=0

Et une modification de mes drapeaux a été faite et j'aimerai bien savoir laquelle pour restaurer ce qui doit l'être.

Merci beaucoup.

David.

clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 26
--------
le 11/04/2019 @ 09:17
par Papinou

Papinou

Administrateur
486 messages

Bonjour,

Dans le mail de confirmation, le membre a un lien pour se connecter et valider son inscription automatiquement.

Je n'ai en aucun cas touché au contenu du site, articles ou autres. Je ne vois pourquoi pour un problème de mail, j'aurais eu besoin de le faire.

Je n'apprécie pas du tout cette allégation !!!

Pöur les drapeaux, je t'ai indiqué dans le mail la modification. il faut remettre tes drapeaux dans inc/lang ce sont en.gif et fr.gif.

Ceux d'origine me paraissent plus approprié pour la taille au moins.

Il y avait un problème de fichiers, mais il y en a un autre entre la chaise et le clavier, et là je n'y peux rien !!!

Pour moi la discussion est close.

Cordialement, Papinou

Je suis membre de l'asso freeGuppY... et vous ???

Site web Papinou
clos par Magellan le 14/04/2019 @ 20:22 Haut  
Réponse n° 27
--------
le 11/04/2019 @ 09:40
par Magellan

Magellan

39 messages

Mais pourquoi tant de colère ? Je n'ai fait que remercier sans jamais rien reprocher alors je ne comprends pas cette réaction. Puisqu'il me faut remettre mes drapeaux, c'est bien que des modifs ont été faites et je ne m'en plains pas au contraire. L'équipe passe du temps pour régler mes problèmes et en remerciements je me plaindrais de quoi que ce soit ? C'est mal me connaître mais en même temps comment se faire un idée en quelques lignes sur ce forum où il faut aller à l'essentiel.

Quant au mail qui soit disant explique comment remettre mes drapeaux, voici la seule phrase qui évoque le sujet :

Citation : « Papinou »

J'ai renvoyé pas mal de fichiers et j'ai oublié tes images pour les drapeaux, tu devras les remettre.

Rien à voir avec "il faut remettre tes drapeaux dans inc/lang". Alors c'est sur que pour les mécaniciens qui assemblent la voiture Guppy tout semble tellement évident mais par pitié ne me jette pas la pierre pour la demande de précision que j'ai formulé sans sous-entendus quelconques.

On vient ici pour bénéficier de votre aide et pas cracher dans la soupe. En tout cas moi je ne me le permettrai jamais.

Quant à l'interface chaise-clavier, en tant que formateur en informatique bureautique (je suis master instructeur Microsoft pour la suite bureautique Microsoft Office) je ne l'ai jamais utilisée car je la trouve blessante et que ce n'est pas parce qu'on fait des erreurs faute de maîtriser un domaine, que l'on est stupide. Mais encore une fois, loin de moi l'idée de donner des leçons mais juste d'exprimer un ressenti.Maintenant puisque la conversation est close, l'interface chaise-clavier va tenter de se débrouiller pour solutionner son problème d'iframe qui n'a donc rien à voir avec ton  intervention (et si cela avait été le cas cela m'aurait été égal) mais que je dois quand même solutionner.

Avec toujours, mes remerciements et rien d'autre. Cordialement David.


Rectifié par Magellan le 11/04/2019 @ 11:01
clos par Magellan le 14/04/2019 @ 20:22 Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter