GuppY, le CMS de référence sans base de données

telecharger.png

Vous êtes ici :   Accueil » Forum » Guppy 5 » PHP insuffisant ?
    Imprimer la page...

Attention : GuppY 6.00.10

Sortie de GuppY 6.00.10 : pack et patch cumulatif et non-cumulatif

Pour passer de la version 6.00.09 à la 6.00.10 vous appliquez le patch non-cumulatif GuppY 6.00.10 .

Pour passer de la version 5.03.03 à la version 6.00.10, vous devez impérativement suivre la procédure de migration décrite dans cet article.
 

Pour les plugins et pour les skins, merci de poster sur le site de leur auteur.

Les skins et les plugins de notre ami Saxbar sont en téléchargement sur ce site.

 

Forum - Guppy 5 - PHP insuffisant ?


Connectés :

  Sujet n° 131520
le 16/02/2022 @ 09:57
par Mireille
visiteur

Bonjour,

Un site Guppy ne fonctionne plus. Sur Google chrome on nous dit que c'est sans doute PHP marie.ma1.free.fr Cordialement et merci pour votre aide

  

Réponse n° 1
--------
le 16/02/2022 @ 17:34
par Schmol44

Bonjour Mireille,

Effectivement :

"Insufficient version of PHP (4.4.3-dev) : 5.1 or higher necessary"

Le Php est en version 4.4.3 et on te demande de passer en Php 5.1 (minimum)

Amicalement, Schmol44

  
Réponse n° 2
--------
le 17/02/2022 @ 08:13
par Mireille
visiteur

Oui merci. Le problème est que je ne sais pas faire. Je vais dans admin ? Php et ensuite ??? Cordialement

  
Réponse n° 3
--------
le 17/02/2022 @ 09:19
par Schmol44

Bonjour,

Non, pas dans "admin".

Tu es chez Free et encore en php 4.4.3. Commence par modifier la version de php : - en ftp tu ouvres le fichier .htaccess - tu supprimes la ligne avec php 1 (si elle existe) - à la place tu mets ceci :

<IfDefine Free>
php5.6 
</IfDefine>

Amicalement, Schmol44


Rectifié par Schmol44 le 17/02/2022 @ 10:47
Rectifié par Schmol44 le 17/02/2022 @ 10:51
Rectifié par Schmol44 le 17/02/2022 @ 10:51
Rectifié par Schmol44 le 17/02/2022 @ 17:37
Rectifié par Schmol44 le 17/02/2022 @ 17:38
  
Réponse n° 4
--------
le 17/02/2022 @ 19:40
par Mireille
visiteur

J'ai suivi vos conseils. Je n'ai pas réussi, mais merci. Cordialement

  
Réponse n° 5
--------
le 17/02/2022 @ 19:50
par Schmol44

Bonsoir,

Quelles ont été vos difficultés ?

Amicalement, Schmol44

  
Réponse n° 6
--------
le 20/02/2022 @ 08:26
par linuxmr
visiteur

Bonjour,

Vous avez ce message

Erreur 500 - Erreur interne du serveur

Le fichier htaccess n'a pas été correctement adapté.

Je vous conseille de changer d'hébergeur assez rapidement, certains hébergeurs permettent de personnaliser la version de PHP et de vous offrir d'autres fonctionnalités PHP plus ouvertes

Bonne journée

Linuxmr

  
Réponse n° 7
--------
le 26/02/2022 @ 10:07
par EdBracame
EdBracame

Bonjour Mireille,

Voila un exemple de fichier .htaccess qui fonctionne chez Free:

<IfDefine Free>
php56 1
</IfDefine>
AddDefaultCharset UTF-8
# Interdire les .php/
<IfDefine !Free>
 RewriteEngine On
 RewriteCond %{REQUEST_URI} ^/(.*).php/
 RewriteRule (.*) - [F]
</IfDefine>
Options -Indexes
<Files ~ "^.ht">
 Order allow,deny
 Deny from all
 Satisfy All
</Files>
<Files ~ ".(inc|dtb)$">
Order allow,deny
Deny from all
Satisfy all
</Files>
ErrorDocument 400 /error.php?err=400
ErrorDocument 403 /error.php?err=403
ErrorDocument 404 /error.php?err=404
ErrorDocument 500 /error.php?err=500

En espérant t'avoir aidé

Gazzzzzzzzz !!!!
Amitiés
Bernard

  
sujet actif   sujet clos   Important!   Nouveau  
Rectifier message   Clôturer sujet   Remonter sujet